System Slowness

Incident Report for CaseWorthy Enterprise Status

Resolved

CaseWorthy teams have identified the root causes for the slowness issues encountered by the customers on the Prod2 server. This was a smaller subset of customers that were impacted. Once the fixes were implemented, the server behavior has been optimal for expected performance.
Posted Sep 08, 2025 - 22:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2025 - 18:57 UTC

Investigating

We have had reports of slowness from some sites and are currently looking into the issue.
Posted Sep 08, 2025 - 17:37 UTC
This incident affected: CaseWorthy Enterprise Web Application.