CaseWorthy Outage

Incident Report for CaseWorthy Enterprise Status

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 16:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2025 - 15:24 UTC

Identified

CaseWorthy had a brief outage this morning. Sites should be back up, but we are looking into and monitoring the issue for now.
Posted Aug 15, 2025 - 15:24 UTC
This incident affected: CaseWorthy Enterprise Web Application.